利用環境について

稼動環境(推奨)

イプシロン決済システムでは、CGI によるデータのやり取りを加盟店様と実施しているため、以下の環境または準ずる環境が必要です。
それぞれの条件に、加盟店様の環境が対応しているかご確認ください。イプシロンで推奨して おりますソフトウェアについては、オープンソース(フリー)なものだけで加盟店様でシステム構築が可能となっており ます(サーバ証明書を除く)。従いまして加盟店様の費用負担が低減されます。

(1) サーバ環境

イプシロン決済システムでは、セキュリティ向上のためオンライン決済受付におきまして、加盟店様ごとにIP アドレス もしくはドメインによる接続制限を実施しております。使用するサーバのIP アドレスまたはドメインは、固定(複数でも 可)であることが必須となります。

サーバを検討中の加盟店様は、以下アドレスを参照していただきサーバの選定のご参考にしてください。
http://www.epsilon.jp/support/answer03.html#01

(2) DB環境

加盟店様環境で購入者様情報、注文情報等を保持するために必要です。加盟店様環境にてデータの保存、もしくは DB 以外の方法で格納する場合は必須ではございません。

参考DB ソフト:Mysql、Postgres、Oracle 等

(3) CGIとやり取りが可能なモジュールが稼動する環境

イプシロン決済システムのCGI とデータをやり取り、もしくは購入者様との情報をやり取りするために必要です。
イプ シロンで推奨している言語は、下記のサンプルにも使用しているPerl となります。Perl 以外のPHP、Ruby、JAVA 等 のhttp(https 含む)プロトコルでの通信が可能である言語であれば問題ございません。

(4) SSL通信が可能な環境

イプシロン決済システムでは、SSL 通信(https プロトコル)を可能としていますので、購入者様の情報を保護する観点 からもSSL 通信が可能である環境が必要です。項番(3)で示したモジュールの実行環境においてもSSL通信を可能とするものが必要です。

<重要>
イプシロンテスト環境および本番環境はグローバルセキュリティ基準「PCI DSS v3.2」に準拠するため、脆弱性が指摘されている暗号化方式(SSL 3.0、TLS 1.0、TLS 1.1)を段階的に閉塞します。

閉塞スケジュール
動作環境 通信環境 閉塞期日
テスト環境

SSL 3.0、TLS 1.0、TLS 1.1 通信の閉塞

2015年11月27日
本番環境 SSL 3.0 通信の閉塞 2016年5月26日
TLS 1.0、TLS 1.1 通信の閉塞 2018年5月末

この通信要件の変更に伴いまして、加盟店様からの通信プロトコルをTLS1.2 に対応していただく必要があります。

接続設定につきまして、詳細は別紙「接続確認手順」を参照ください

(5) 外部システム(購入者様)のWebブラウザから通信可能な環境

イプシロン決済システムは、購入者様-加盟店様との通信についてhttps(http 含む)プロトコルを使用していますので、購入者様のWeb ブラウザより加盟店様のシステムに対して接続可能なシステム(ソフトウェア)およびネットワーク の構築が必要です。
項番(4)の通信要件の変更に伴いまして、加盟店様および購入者様のWeb ブラウザでTLS1.2 通信を可能にする必要があります。

(6) xml形式のデータを解析可能なモジュール

イプシロン決済システムからの応答は、XML 形式で記述されておりますので、それを解析するモジュールが必要で す。

(7) サポートされるブラウザ環境(トークン決済)

トークン方式は、Javascriptの動作するブラウザを前提としております。Javascriptの利用できない端末(一部フィーチャーフォン等)では、トークン方式をサポートいたしません。
以下に記載したOS/ブラウザにて動作確認を行っております。

≪動作確認済みのOS/ブラウザ≫※いずれも日本語版となります。
Windows10 / Microsoft Edge 25、Internet Explorer 11、FireFox 48、Google Chrome 52
Windows7 / Internet Explorer 11、FireFox 48、Google Chrome 52
Mac OS X 10.10 / Safari 9.1.2

動作未確認のOS/ブラウザでも利用可能な場合があります。

動作確認済のOS/ブラウザをご利用の場合でも、エンドユーザのご利用環境(設定、通信速 度等)によって正しく利用できない場合があります。

Internet Explorerは、version 11 以降の標準モードのみサポートされます。(Quirksモードでは動作いたしません。)

動作確認環境は随時更新されます。記載したバージョンのメーカーサポートが 終了した場合や新しいバージョンがリリースされた場合、記載内容から削除される場合があります。